Forum » The Geeks Corner » Linux » Sudo Commands for Linux » Adjust your Mouse Speed

Adjust your Mouse Speed

  • How to adjust your mouse speed down with high DPI's will be just to fast to use in Linux)
    If you have a 3200 DPI or higher mouse most likely you will need to do this.
    First go to Settings Mouse and Touchpad and see if you can slow it down. For me 6400 DPI
    the slowest setting was twice the speed of light! LOL
    Find Device Name in Terminal - use either device name "My Really Fast Mouse" or ID# "8"
    xinput --list --short (will show you your mouse & keyboard names)
    xinput --set-prop "8" "Device Accel Constant Deceleration" 3
    (test different numbers until you find one the works for you 1 to 5 should do it)

    Use a text editor and save as .sh (gedit will not work) mousepad worked for me.
    #!/bin/bash
    # My Fast Mouse speed (Just so you what it does)
    xinput --set-prop "8" "Device Accel Constant Deceleration" 3
    You will need to save it to Documents or another folder, change type of file to sh.
    mouse-fix.sh

    Next move it to the Bin folder open a terminal window.
    useranme:~/$ cd Documents (or what ever folder you saved the file to)
    username:~/Documents$ sudo mv mouse-fix /usr/bin
    Then go to that folder and right click on the file you just made, properties,
    select Allow this file to run as a program.

    Then go to Settings/Sessions and Startup click add, look for your mouse-fix where ever 
    you decided to keep it. Give it a name and description, click OK Now your mouse should run 
    at normal speeds on start up :)
    My System:
    Case: Thermaltake Core V71 Tempered Glass.
    Motherboard: Asus Prime TRX40-Pro.
    CPU: AMD Threadripper [email protected] OC.
    Water Block: EK Velocity sTR4 copper & nickel.
    Radiator: Thermaltake Pacific CL429 64mm pure copper.
    Water Pump & Res: 320 GPH Pond Pump, 5 Gallon Reservoir.
    Memory: 64 gigs Corsair Vengeance DDR4-3600 18-19-19-39 CR1.
    Video Card: EVGA RTX 2080 TI XC Ultra
    Hard Drives: 1 Crucial 256gig M550, 3 Crucial 2TB SSD's,
    1 Western Digital 5TB 128meg cache, 2 Seagate 4TB 256meg cache.
    Power Supply: Corsair 1050 watt SINGLE RAIL.
    OS's: LINUX Xubuntu 20.04 LTS x64 and Windows 10 Pro 2004.
      December 9, 2017 10:41 AM PST
    0
  • Update August 17 2018 - for Ubuntu 18.04.1 

    Same failure on the mouse adjustments and they have removed "Device Accel Constant Deceleration" with that you could really tune the mouse to just the speed you wanted. :(

    With that removed you can slow it down to just below light speed almost unusable :( I have tried almost every setting but most don't change anything.

    So start in a Terminla Window again same as before get the device ID:
    Type: xinput --list --short (hit enter)
    You should see something like this in the terminal window. Then find your mouse mine
    is DEXIN Corp. Tt esports Black Element id=8 I have profiles on the mouse that I can
    adjust by opening windows 8 in VM, adjust the mouse, select that profile in Linux.


    Next you need to find the settings for your mouse.
    In the terminal windows type:  xinput list-props 8 (hit enter)
    You should see something like this. Again THIS IS ONLY Ubuntu in my case Xubuntu 18.04.
    The line you need in this version is "libinput Accel Speed (296): 0.100000".
    Default is "libinput Accel Speed (296): 0.000000" 


    Then you will want to try a few speeds to see what works for you. There isn't much adjustment the old
    way was much much better! I guess Ubuntu hasn't figured out IF IT'S NOT BROKEN DON'T FIX IT! There
    are standard mouse and touch-pad adjustments under the menu (You only have a menu when you upgrade
    to Xubuntu or some other distro of Ubuntu) Ubuntu says Unity is gone but you are still stuck with no menu,
    the HORRIBLE and may I say STUPID side app bar! On a menu in settings "Mouse and Touchpad" or you can
    look for a picture, search for it because menu's are to hard to read? LOL Even with those settings at 0 my 
    mouse is twice as fast as lightning!
    So going back to terminal type this in: xinput set-prop "8" "296" "0.1" (hit enter)

    I did try every setting. :( 1.0 makes it faster (2.0, 3.0 and up gives an error). 0.1, 0.01, 0.001, 0.0001, 0.00001 and 0.000001. I also tried every number for 1 to 9 I didn't really see any difference in speed (SLOWER) except 0.1 or 0.01.

    Everything else in the top post works as far as using the file "mouse-fix" to set the speed on start-up. If you upgraded like I did you can just edit the old file and remove the command THAT WORKED!!! (xinput --set-prop "8" "Device Accel Constant Deceleration" 3)
    And add this: xinput set-prop "8" "296" "0.1"

    You will also need to add it back to your start-up session.

    If it's a clean install you will need to do all the steps above.

    This mouse speed problem has been a problem in Linux for about 10 years! I'm guess the default speeds are for a really basic and slow mouse? Maybe for a 2000 to 3200 DPI mouse because a 6400 DPI mouse is nuts! LOL

    Like I said earlier I have 5 profiles that program to the mouse so I can get it working with that & the mouse-fix file.
    My System:
    Case: Thermaltake Core V71 Tempered Glass.
    Motherboard: Asus Prime TRX40-Pro.
    CPU: AMD Threadripper [email protected] OC.
    Water Block: EK Velocity sTR4 copper & nickel.
    Radiator: Thermaltake Pacific CL429 64mm pure copper.
    Water Pump & Res: 320 GPH Pond Pump, 5 Gallon Reservoir.
    Memory: 64 gigs Corsair Vengeance DDR4-3600 18-19-19-39 CR1.
    Video Card: EVGA RTX 2080 TI XC Ultra
    Hard Drives: 1 Crucial 256gig M550, 3 Crucial 2TB SSD's,
    1 Western Digital 5TB 128meg cache, 2 Seagate 4TB 256meg cache.
    Power Supply: Corsair 1050 watt SINGLE RAIL.
    OS's: LINUX Xubuntu 20.04 LTS x64 and Windows 10 Pro 2004.
    This post was edited by beast-usa (Admin) at August 17, 2018 8:40 PM PDT
      August 17, 2018 8:37 PM PDT
    0